Google Blogoscoped

Forum

UK Google sites in Greek

Guy Weston [PersonRank 1]

Wednesday, April 23, 2008
10 years ago2,429 views

Has anyone else noticed that some Google UK pages are displaying what I think is Greek text rather than English?

I've noticed it on the Analytics login page, where the search box has Greek text and have now found the entire accounts help section is coming through in Greek. Anyone know why?

I'm assuming it's Greek – here's a sample...

Особиста інформація – Редагувати
MCC[put at-character here]coolpink.net
Країна: Великобританія (United Kingdom)
Часовий ояс: (GMT+00:00) Лондон
Змінити електронну ошту
Змінити ароль

Ionut Alex. Chitu [PersonRank 10]

10 years ago #

That's Russian, not Greek. Change the language in Analytics by clicking on the link next to your email address, selecting UK English from the dropdown and clicking on the default button.

Guy Weston [PersonRank 1]

10 years ago #

Thanks for clearing that up – I really had no idea what language I was looking at!

It's not the language settings – I can be on pages in English, click a link and suddenly it's all in Russian. I'm also getting parts of the page in English and parts in Russian – I'm going to put some screen shots on a URL which I'll post in a moment.

Is anyone else experiencing this?

Guy Weston [PersonRank 1]

10 years ago #

Screen shot is at www.kulturcineclub.co.uk/google-analytics.png

Look at the top right – Russian search box text, language set to UK English and rest of page in English. Have seen this much worse but can't replicate it at the moment. Will post another screen shot if I do manage it!

Mrrix32 [PersonRank 10]

10 years ago #

Hmmm I'm seeing this as well.

Blame the Americans! ;-D

Guy Weston [PersonRank 1]

10 years ago #

I've managed to replicate this on a the My Account page, with mixture of English and Russian – screen shot at


kulturcineclub.co.uk/google-my ...



I've also seen this on help pages – it's happening more and more, with more of the page affected each time. It's becoming a bit of a problem on occasion because I just can't find the functions I need when things are written in Russian and have trouble getting it back into English.

[Formatting fixed – Tony]

Tony Ruscoe [PersonRank 10]

10 years ago #

I think somewhere along the lines, something is switching your account to Russian. Once in your account, add "?hl=en" to your URL or click this link:

www.google.com/accounts/Manage ...

That will hopefully reset your language preferences for your Google Account. Let me know how you get on.

Fahad [PersonRank 1]

10 years ago #

I am also encountering this problem everytime I log in to google analytics then click on account it is displayed in russian and I can not understand how to change it I have some parts of it in English from when I log in straight away but when click on accounts the text is changed into russian.

Also I have gone into settings and in the drop down menu selected UK english and tried to save this but when click on the save prefences button nothing happens.

Does anyone have any advice on how to get around this situation?

This thread is locked as it's old... but you can create a new thread in the forum. 

Forum home

Advertisement

 
Blog  |  Forum     more >> Archive | Feed | Google's blogs | About
Advertisement

 

This site unofficially covers Google™ and more with some rights reserved. Join our forum!