Google Blogoscoped

Forum

Odd Things Going On at Experts Exchange  (View post)

Varun [PersonRank 3]

Tuesday, July 14, 2009
10 years ago7,377 views

Really strange. Though now-a-days stackoverflow.com works fine for me

Benjamin [PersonRank 0]

10 years ago #

Actually, everytime I get a hit for expert-exchange.com and I normally visit the page (through the Google link), I can scroll down past the footer and get the actual responses instead for the question. I think this happens everytime you visit the page with a Google referrer.

DiGi [PersonRank 1]

10 years ago #

There is a secret – just scroll doooown at bottom of page... :-)

Ino Detelic [PersonRank 1]

10 years ago #

well the post says that doesn't work anymore, I've tried and it's obfuscated.

and the page source shows nothing.

Ino Detelic [PersonRank 1]

10 years ago #

I tried again but now it works as usual, in the bottom.

goog for: site:www.experts-exchange.com iphone

I can see the results in the bottom.
But when you search the question pages from within expertsexchange, it shows nothing.

so if you come through goog, you see it, from sexchange, you don't... So there's clearly a difference in what goog sees and the way you see the page from within the site.
amirite?

Philipp Lenssen [PersonRank 10]

10 years ago #

> There is a secret – just scroll doooown at bottom
> of page

This did not work for me, as described. (Neither did it work for my friend, who was also expecting that scrolling way down would help as usual.)

> so if you come through goog, you see it, from sexchange,
> you don't

This too did not work for me. I was coming from Google, and still did not see the answer (when scrolling way down).

Ino Detelic [PersonRank 1]

10 years ago #

for that specific question you mentioned in your post, search for:

site:www.experts-exchange.com How do I subtract the current time till the end of the day in PHP

I got the answers in the bottom as usual. If you don't maybe it's country-specific or something? I doubt.

Philipp Lenssen [PersonRank 10]

10 years ago #

> for that specific question you mentioned in your post,
> search for:
>
> site:www.experts-exchange.com How do I subtract the
> current time till the end of the day in PHP

For that search, as for the others, I get the exact same all-answers-hidden-and-nothing-at-the-way-bottom behavior (I'm in Germany):


blogoscoped.com/files/experts- ...



(Yes, above screenshot shows the page as it is scrolled to its way bottom end.)

Ino Detelic [PersonRank 1]

10 years ago #

I changed the user agent to googlebot 2.1 and slurp, and I can see the answers by going directly to the site with the link, no search.

with the default useragent in ff3 and chrome, following directly the link shows the hidden page.

I'm in portugal, but that shouldn't matter.

Todd Vierling [PersonRank 1]

10 years ago #

This behavior is indeed a violation of "first click free", and I'm not surprised that E-E would try this. It's something that academic journal sites did for ages until GOOG basically said "if youre going to index the full page, then the user must get the full page, else we're going to blacklist you from the index".

It's worth reporting to Google's policy enforcement.

moo [PersonRank 1]

10 years ago #

ah well, at least experts-exchange is going to lose so much of its googlejuice to stackoverflow.com that it'll be irrelevant in a year or less

Musaul [PersonRank 0]

10 years ago #

I thought experts exchange has been like this for quite a while now. at least a year?

I just have Google Bot as one of the UAs in the User Agent switcher add-on in Firefox. comes in handy for things like this.

Seth Petry-Johnson [PersonRank 0]

10 years ago #

I've been seeing this for awhile now. I've just stopped clicking to we results altogether... SO FTW IMHO

Gustavo Muslera [PersonRank 1]

10 years ago #

Their result always result top or close to top in most tech searches i do in Google. And no, scrolling gives no info (I'm not in US).

Lately been deleting their results in the results page, as is no answer at all for my questions (unless i register, and maybe get premium account even), but still I'm deleting individual results and not banning the entire site.

Piwate [PersonRank 0]

10 years ago #

Argh, now you've blown the cover and they're sure to fix it.

JohnMu [PersonRank 10]

10 years ago #

It works for me (using my Swiss DSL) – are you sure you have referrers turned on? Can you post the URL of your search results page?

Dinah [PersonRank 0]

10 years ago #

The full code is there but somehow they cover it up. Look at the source code and the answer will near the bottom. I can see it fine in Firefox but not in IE. I wonder if some of my Firefox add-ons have had the added benefit of unmasking them.

Either way, Stack Overflow is infinitely better and should overtake E-E very soon. It would be nice if google actually enforced their own policies and blacklisted them though.

JohnMu [PersonRank 10]

10 years ago #

Dinah, here's an answer from Matt Cutts about the site:

+ Show video

Thomas [PersonRank 0]

10 years ago #

I am entering the internet via proxy and both with regular FF UA and Googlebot I can see the solution when I scroll to the bottom. I didn't know this before and always ignored E-E results anyway because nearly always the solution can be also found somewhere else.

Philipp Lenssen [PersonRank 10]

10 years ago #

> It works for me (using my Swiss DSL) – are you sure
> you have referrers turned on?

Update added: Turns out my referrer was not sent – so apparently the only sneakery going on here is the one that's officially sanctioned by Google, "first click free". (Google allows sites to confuse people and show something else to users than is shown to Googlebot & Google users, and a way to implement this checks the referrer value, which you can turn off in the browser options.) Turning on the referrer, I can now see the Experts Exchange solution by scrolling way down to the bottom, as usual for the site. [Thanks JohnMu!]

JohnMu: Just to clarify, does Google allow sites to hide the crucial content when the referrer is turned off in the browser settings, and show everything to Googlebot? (I suspect so, as it might look like the person might have entered the address directly or accessed a bookmark.)

JohnMu [PersonRank 10]

10 years ago #

If most of the users are able to see the same content as Googlebot sees, that's generally fine. There are always some edge-cases that might not be reasonably possible to deal with (eg obsolete browsers, no referrers, etc.).

Michael [PersonRank 0]

10 years ago #

i observed this behaviour for some time now. aprarently it's connected to me using google chrome a lot lately. it still works ok in firefox but not in google chrome. does this mean that google chrome does not send the referrer per default? i cannot find any references on how to turn on.

anybody knows something?

Philipp Lenssen [PersonRank 10]

10 years ago #

> If most of the users are able to see the same
> content as Googlebot sees, that's generally fine.

Surely you must mean "most of the *Google* users"... First Click Free doesn't care about users coming from other sites.

JohnMu [PersonRank 10]

10 years ago #

Philipp, you're right, you're obviously free to do whatever you wish with users who come from elsewhere :-).

Michael, a quick way to check for your referrer from search results is to search for [phpinfo http_host] and to click on one of the "phpInfo()" pages shown. You can find the referrer next to "HTTP_REFERER".

Michael [PersonRank 0]

10 years ago #

thanks JohnMu

that's what i'm observing:

1. google search for phpinfo http_host

then using firefox (3.0.8) the result is:
- click on any phpInfo() link directly to open in same window: HTTP_REFERER present
- click on any phpInfo() link to open in new tab or window: HTTP_REFERER present

doing the same with google chrome (2.0.172.33) the outcome is:
- click on any phpInfo() link directly to open in same window: HTTP_REFERER present
- click on any phpInfo() link to open in new tab or window:!!HTTP_REFERER NOT PRESENT!!

probably a bug?

Michael [PersonRank 0]

10 years ago #

sorry for spamming here, above described behaviour seems to be a known bug in chrome:

code.google.com/p/chromium/iss ...

sohilv [PersonRank 0]

10 years ago #

Its because of the Google bot user agent in browser. if you set it to
"Googlebot/2.1" any page will show the answer.
I tried in FF its works fine.

Tom Coady [PersonRank 1]

10 years ago #

"Turns out my referrer was not sent"
How do you enable that?
Does that not break the internets?
Which browser were you using?

Philipp Lenssen [PersonRank 10]

10 years ago #

Tom, to hide your referrer in Firefox, type "about:config" into the address bar and hit return. Now in the filter box that will show, enter "referer" (yes, mispelled with one "r" in the middle, not two). You should see the value "network.http.sendRefererHeader", and its value to the way right is probably "1". Double-click the item and replace the value with "0", and hit OK. Not sure if you now need to restart the browser, but otherwise, you're now set up and are hiding your referrer.

Tom Coady [PersonRank 1]

10 years ago #

Thanks Philipp – glad to see it's not /that/ easy as it would bring less to the analytics party if everyone did that. If anything I'd like the opposite, so I can read NYT articles without the google referrer :)

Philipp Lenssen [PersonRank 10]

10 years ago #

Update: Odd, my friend who sent me this says he did not disable the referrer – indeed, in his browser, the referrer, is on, and he says he never changed the setting. (Now, when he tries it again, he can see the content though, as opposed to last time.)

This thread is locked as it's old... but you can create a new thread in the forum. 

Forum home

Advertisement

 
Blog  |  Forum     more >> Archive | Feed | Google's blogs | About
Advertisement

 

This site unofficially covers Google™ and more with some rights reserved. Join our forum!