Google Blogoscoped

Forum

[Pet peeve] Undesired local links in the top bar

Jérôme [PersonRank 10]

Sunday, July 4, 2010
9 years ago7,620 views

I live in France but I prefer google.com over google.fr as I do most of my searches in English. To do so, I click "Go to Google.com" at the bottom of the Google homepage and the cookie remember my preference.

Unfortunately, the mobile version of Google doesn't respected your choice in spite of the "go to google.com" link available on google.fr. Indeed, most of the hyperlinks in the top bar (Reader, Documents...) keep directing you to local versions of these services. That's very annoying because English searches on google.fr are crappy and because changing your preferences every time you navigate between services is a big waste of time.

My problem is that the issue is no longer limited to mobile, which means that I can't use the top bar on any Google services without losing my language preferences.

Do you know if it's a bug? Do you encounter this issue? Do you know any workaround?

Thanks for your help!

PS: issue reported in the official forum google.com/support/forum/p/Goo ...

Ionut Alex. Chitu [PersonRank 10]

9 years ago #

This problem occurs increasingly often. The solution is to go to the homepage and click on "google.com in English" or go to google.com/ncr, but it's just a temporary solution. Sometimes clearing the cookies might help.

Jérôme [PersonRank 10]

9 years ago #

I'm on an iPhone and I can't go to either google.fr or google.com without being redirected to sorry.google.com/sorry/. Solving the captcha does nothing and my browser data are clean (no cache, no cookie). I've the feeling that this (extremely annoying) issue is related to the .fr > .com issue, even though it could be from my network provider (Orange France, but there's no similar report on Twitter) or from my terminal (but my iPhone has been fully formatted+reinstalled) minutes ago.

Do you know how I can fix that? Do you think it could be related to the problem mentionned above?

By the way, do you know how I can force the iPhone to search google.com by default instead of .fr? I can't believe both Apple and Google care so little about this kind of issue – e.g did you know that an iPhone set up in English appends "United States" at the end of any addresses of your Contacts when you use them in the maps app? From my (ruined) experience, it's a great way to get you lost!

Ionut Alex. Chitu [PersonRank 10]

9 years ago #

<< I'm on an iPhone and I can't go to either google.fr or google.com without being redirected to sorry.google.com/sorry/. >>

That usually has to do with automated requests from your network. Try using the Google Mobile App or switch to a different international domain: for example: google.co.uk.

<< do you know how I can force the iPhone to search google.com by default instead of .fr? >>

I've solved this problem by choosing the "United States" locale from Settings/General/International/Region Format. "Language" is a separate setting.

This thread is locked as it's old... but you can create a new thread in the forum. 

Forum home

Advertisement

 
Blog  |  Forum     more >> Archive | Feed | Google's blogs | About
Advertisement

 

This site unofficially covers Google™ and more with some rights reserved. Join our forum!