Google Blogoscoped

Forum

Blogger languages

C├ędric [PersonRank 1]

Saturday, November 13, 2004
16 years ago

Apparently, only portions of Blogger are translated. Yesterday, only the homepage was translated in French, today they added the dashboard.

I am using two computers, one set in English, the other in French. It seems that if Windows (not your browser) is in English, Blogger displays in English.

Andreas [PersonRank 0]

16 years ago #

The language you get depends on the "Accept-Language" header your browser sends. Compare the following two queries I sent in order to see how blogger decides which language to present:

GET / HTTP/1.1
Host: www.blogger.com
User-Agent: Mozilla/4.0
Accept: text/xml,application/xml, application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8, image/png,*/*;q=0.5
Accept-Language: de,en-us,en
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Accept-encoding: gzip, deflate

=> "Erstellen Sie einen Blog in 3 einfachen Schritten"

GET / HTTP/1.1
Host: www.blogger.com
User-Agent: Mozilla/4.0
Accept: text/xml,application/xml, application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8, image/png,*/*;q=0.5
Accept-Language: en-us,en
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Accept-encoding: gzip, deflate

=> "Create a blog in 3 easy steps"

The Proxomitron local proxy makes it easy to edit the headers you send :-).

--
aiplayground.org

Philipp Lenssen [PersonRank 10]

16 years ago #

The "accept-language" headers should depend on the browser language settings. That's content-negotiation, but it doesn't look as if Blogger would respect it. After all, I can do it myself on sites like Findforward.com and it works with my browsers...

Andreas [PersonRank 0]

16 years ago #

Is there any other way Blogger could determine your preferred language? Of course, they could trace the ip back to your country – but apparently they don't: I'm in Germany and the language I get depends on the Accept-Language-header my browser sends.

Did you try clearing your cookies? Visiting blogger.com with another browser?

By the way, I just tried to change the order of Opera's list of preferred languages – and blogger changes the language of the interface just fine.

--
aiplayground.org

Philipp Lenssen [PersonRank 10]

16 years ago #

I just removed my cookies, and now it worked! I don't know if that was it, but it looks so. Thanks!

Philipp Lenssen [PersonRank 10]

16 years ago #

PS: Google.com definitely traces my IP to do geo-location (but I can easily click on "Google in English" and it wil set a cookie).

Pierre [PersonRank 0]

16 years ago #

Biz has made it public in both the Googleblog and Blogger.com

This thread is locked as it's old... but you can create a new thread in the forum. 

Forum home

Advertisement

 
Blog  |  Forum     more >> Archive | Feed | Google's blogs | About
Advertisement

 

This site unofficially covers Google™ and more with some rights reserved. Join our forum!