Google Blogoscoped

Forum

Google Maps Chessboard bug fixed

Philipp Lenssen [PersonRank 10]

Tuesday, June 24, 2008
12 years ago2,933 views

I often had gray tiles when visiting Google Maps (blogoscoped.com/archive/2007-0 ...). Now someone from Google helped me, as well as Tony who had the same problem, fix this (well, apparently... I didn't get any gray tiles so far): all we had to do was to disable the firewall of the DSL modem/ router. For instance, for T-Sinus 154 DSL, I accessed 192.168.2.1 and turned off the firewall in the settings, using the Windows Vista firewall instead.

callum [PersonRank 2]

12 years ago #

I get this chessboard pattern ever since I moved to using an iMac and Leopard with Firefox 2. I don't get it using Safari on the same system. I don't get it using Firefox 2 on a MacBook Pro running XP under Bootcamp.

If it is caused by my router firewall then it must be some interaction with OSX and Firefox (which sounds very unlikely).

Kirby Witmer [PersonRank 10]

12 years ago #

That's not a good idea at all. I'm surprised they would even recommend such a thing.

Philipp Lenssen [PersonRank 10]

12 years ago #

Kirby, the person from Google just clarified to me that it was more intended as a kind of tech-savvy user hack, I suppose at your own responsibility, rather than official Google advice. Perhaps it's best suited if your DSL firewall is really bad, and in my case was suggested because I had the Vista firewall anyway...

Colin Colehour [PersonRank 10]

12 years ago #

So your firewall blocks the tiles from downloading completely so you would get some grey undownloaded images and other tiles would be downloaded fine? Why would a firewall allow half through but not all?

Kirby Witmer [PersonRank 10]

12 years ago #

Philipp,

that makes sense. Just don't ever turn your Vista firewall off. :)

i've worked on way too many computers that didn't have a firewall.... you will pay for it sooner or later if you don't have one.

Tony Ruscoe [PersonRank 10]

12 years ago #

Just to clarify something: I think you can also get this problem if you've messed with certain settings in your Firefox config. But since my problem was the same in IE7 and FF2, we knew it was nothing to do with my browser settings. It also only started happening when I changed my wireless router recently (although I wasn't sure of this at the time).

Roger Browne [PersonRank 10]

12 years ago #

Many DSL modem/routers have settings for "Denial of Service" prevention. Perhaps with so many individual tiles coming through, some kind of threshold is triggered? If it's not due to that, it would be interesting to know just what the problem is caused by.

I would really be reluctant to disable the firewall on my DSL modem. In my experience, the operating system's firewall settings can too easily be changed during software updates, reinstallation etc.

Tony Ruscoe [PersonRank 10]

12 years ago #

I completely agree Roger. This has confirmed where the problem lies but it's not really a suitable fix. I turned my router's firewall back on immediately after testing the theory.

This thread is locked as it's old... but you can create a new thread in the forum. 

Forum home

Advertisement

 
Blog  |  Forum     more >> Archive | Feed | Google's blogs | About
Advertisement

 

This site unofficially covers Google™ and more with some rights reserved. Join our forum!