Google Blogoscoped

Forum

How to stop Google Desktop opening Internet Explorer?

photoactive [PersonRank 10]

Tuesday, February 13, 2007
13 years ago5,884 views

Annoying, this: I downloaded an update to Google Desktop (as suggested by the Google updater) and now the quick search box – the thing that comes up when you press CTRL-CTRL – brings up the SLOW Windows Internet Explorer 7 rather than Firefox as it did before. (Firefox is my default browser.) Why is it opening a non-default browser? And does anyone know how to fix it?

photoactive [PersonRank 10]

13 years ago #

There's another apparent bug with the latest version of Google Desktop, here at least: when you change preferences and save your changes the quick search box pops up (as if you'd pressed CTRL-CTRL).

asdf [PersonRank 1]

13 years ago #

weird, if you are set to firefox, it should always open firefox. At least it does for me

photoactive [PersonRank 10]

13 years ago #

It did for me too until this morning, when I downloaded the update. Also, clicking on the Desktop icon in the system tray is now bringing up Explorer. I don't normally use the sidebar but when I bring it up all links now lead to Explorer.

It might NOT be to do with the update – perhaps something else has changed on my system – but Firefox is still set as the default browser.

fixeruper [PersonRank 0]

13 years ago #

For the longest time Google Desktop Search always displayed my search results in Internet Explorer rather than Firefox, my default browser. Try as I might I could not make GDS understand that my default browser really is Firefox and not that blasted IE.

It turns out GDS looks for browser handling instructions in a dimly lit and dusty corner of the Windows Registry, a place not subject to the commands sent from the “Set Program Access and Defaults” applet or “Tools | Options | Default Browser” setting. If you would like to sever ties completely between GDS and IE, here’s how:

   1. Open the registry editor: regedit
   2. Find: HKEY_CLASSES_ROOThtmlfileshellopencommand
   3. You will likely see a string value with the full path to iexplore.exe. Replace the value with: "C:Program FilesMozilla Firefoxfirefox.exe" -nohome
   4. Enjoy GDS once again.

I found this solution in the archives of the Google Desktop Google Group. Thanks CB!

One final note for those who’ve installed the latest GDS v3 beta, do not enable “search across computers.” At this point, it’s an unnecesarry privacy and security risk. More on that here and here.

This thread is locked as it's old... but you can create a new thread in the forum. 

Forum home

Advertisement

 
Blog  |  Forum     more >> Archive | Feed | Google's blogs | About
Advertisement

 

This site unofficially covers Google™ and more with some rights reserved. Join our forum!