Google Blogoscoped

Forum

When Firefox gets slow...

Philipp Lenssen [PersonRank 10]

Wednesday, June 20, 2007
13 years ago5,926 views

I was wondering if I'm the only one with this Firefox issue, and if there's a better solution than mine.

Often after browsing some time (I don't use tabs, and have several windows open), Firefox gets very slow. E.g. shift-clicking a link may take 3 seconds instead of 0.5 to open a new window. In that case, when the problem persists, I can close all Firefox windows, but then always notice that Firefox is still in the running tasks when I hit Ctrl+Alt+Del. If I kill the FF instance from the task control panel and start a fresh FF window, it will be quick as usual again (just restarting FF without explicitly killing it won't work tho).

stefan2904 [PersonRank 10]

13 years ago #

extensions?

Roger Browne [PersonRank 10]

13 years ago #

Yep, extensions. Uninstall them all, then start again with the ones you really need.

Philipp Lenssen [PersonRank 10]

13 years ago #

Interesting... out of the 3 official Google extensions I have, 2 (Gears, Photos Screensaver) Google won't let me remove immediately (the uninstall button is ghosted, probably because I need to uninstall the software itself through the Windows software control panel). I can disable them though...

Search-Engines-Web.com [PersonRank 10]

13 years ago #


Disabling should do just fine.

But open the RESOURCE MONITOR in the WINDOWS TASK MANAGER – there is a wealth of real-time info to aid in detecting what really is the problem

David Hetfield [PersonRank 10]

13 years ago #

Speaking of Firefox problems, I have one.

When i download any type of file, it won't save it in my " Downloads " section. (plus, i can't download pictures)

Anyone knows how to fix this maybe?

Thanks,
David

Roger Browne [PersonRank 10]

13 years ago #

David: you mean the FireFox "opens" the file in some application instead of giving you a "Save As" dialog box? Go to "Edit Preferences", click the "Downloads" icon, click "View & Edit Actions" and remove any Actions that are occurring automatically.

(For FireFox 1.5 on Linux, your kilage may vary).

David Hetfield [PersonRank 10]

13 years ago #

Not exactly.
It gives me the option of – Save As , or Open. but when the download is complete, it won't show up in the Downloads section (Ctrl+J)

Colin Colehour [PersonRank 10]

13 years ago #

[put at-character here]David, Open up your Preferences, Select the Privacy tab and click the checkbox next to "Remember what I've downloaded". That will allow you to see all completed downloads from that point on.

David Hetfield [PersonRank 10]

13 years ago #

Yeh,
Thing is, it's already been marked.. :/

Colin Colehour [PersonRank 10]

13 years ago #

Do you have any extensions that deal with downloads? Those might be interfering with the browsers main preferences.

David Hetfield [PersonRank 10]

13 years ago #

I don't think so..
These are all my add-ons.


img527.imageshack.us/img527/10 ...



You recognize anything that might be causing the problem?

James Xuan [PersonRank 10]

13 years ago #

I notice Video Downloader is on the list. Did you get this from the recommendation I made a while back?

Colin Colehour [PersonRank 10]

13 years ago #

[put at-character here]David, It's possible your Downloads.rdf file is corrupt. You could try shutting down Firefox, then remove the file and then re-open Firefox. Try downloading something and see if it stays in your Download list after it completes.

kb.mozillazine.org/Downloads.r ...

Zim [PersonRank 10]

13 years ago #

My suggestion is easier: swtich to Opera. It's not the better browser for Google lovers, but it manages cache better, and uses less memory.
Firefox is gone for me until they solve the use_memory_till_explode issue.

David Hetfield [PersonRank 10]

13 years ago #

[put at-character here]James,
Could be. I don't remember really.

[put at-character here]Colin
Thanks. I'll use your advice later-on today, and post what happened.

[put at-character here]Zim
No thanks Zim.I'm already used to Firefox, and i don't think one flaw should make me switch browsers.

Rohit Srivastwa [PersonRank 10]

13 years ago #

Even i had few of the above mentioned problems

Upgrading my FF & keeping it updated solves all these issue.
my current is 2.0.0.4 & no more pain.

IF you haven't updated, try it once.

David Hetfield [PersonRank 10]

13 years ago #

My browser is always up to date. But thanks :)

JohnMu [PersonRank 10]

13 years ago #

I have a batch file that kills the Firefox process and starts it again – then I just have to select "restore session" :-). The lazy man way. I've noticed that mine slows down when I have a lot of tabs open, as if some javascript somewhere is left running in the background (perhaps from one of the many web2.0 sites, bah).

Suresh S [PersonRank 10]

13 years ago #

Disable Extension whichever is not necessary

David Hetfield [PersonRank 10]

13 years ago #

It Worked!!!!

Thanks a lot Colin!!! :D

Rian [PersonRank 1]

13 years ago #

Hey all,
I stumbled across this forum looking to solve the exact same "hanging" problem with firefox. I used to run about 3-4 instances of ff, each with 7-8 tabs, yes, sometimes 36-40 tabs open (or more), no performance hits at all. Now, I believe since the automatic upgrades that ff has implemented, I may have as few as two ff windows with two tabs each and ff goes into "stupid mode". I can't switch between one ff window and another, and can't switch between one tab or the other. Suddenly ff will free up and function normally for about 30 seconds. Same as above, if I kill it off in task manager (where it's using 48% of system resources) it will be ok for a while, but the slow down will return. I already did these adjustments:
Set “network.http.pipelining” to “true”
Set “network.http.proxy.pipelining” to “true”
which seemed to work for a while, but the slowness came back pretty quickly afterward, so I'm not sure it did anything at all. Someone mentioned extensions... not sure where to find those but if anybody has some insight into what is wrong with firefox --- this has to be a widespred problem --- please help. My days are getting wasted waiting for this browser to respond and I don't want to go back to IE!

Rian [PersonRank 1]

13 years ago #

btw... I'm on V.2.0.0.4

Steven Marzuola [PersonRank 1]

13 years ago #

Philipp and Rian, I'm having the exact same symptoms you are. I have V.2.0.0.4, and use about 15 extensions, for probably about a year without major changes. A few weeks ago I installed Down Them All, to download a couple of hundred files from a customer's portal. I didn't notice anything bad until a week or so later, when it started taking forever to switch between tabs. I haven't timed anything, but it's easily 3 seconds or more. Task Manager tells me that the CPU usage is pegged to the max during this time.

I have run virus and spyware scans, nothing. Uninstalled Firefox, but didn't clean everything out correctly because it still had the same extensions. Uninstalled all of them, then started adding them back one or at a time. After the third or four one, it it got bad again. I have added a new button to my QuickLaunch to start it in safe mode, which is much faster, but I don't like living without NoScript.

Thomas [PersonRank 0]

13 years ago #

Finally, someone is admitting to having the switch tabs problem

It's totally insane, happens after about 8 tabs, never used to happen in 1.5. Total BS. I'm using Opera now.

Brian [PersonRank 0]

13 years ago #

Me too! I'm really pissed off about Firefox 2.0.0.4. I was totally happy with 1.5 and foolishly agreed to upgrade when the nag screen appeared. Now it's a complete dog.

Brian [PersonRank 0]

13 years ago #

I think it may have been the Google toolbar that was causing the slowness – I disabled first Pagerank and then the entire toolbar and things improved a lot. Still not as fast as 1.5 but at least I can click on another tab now after clicking a link! Apologies to any Firefoxers reading this for my bad-mouthing your work!

Art-One [PersonRank 10]

13 years ago #

When I watch on-line video I've also noticed that Google Desktop Search is a speed killer. Video is always hooky with GDS on, when I put it off video runs smoothly...

This thread is locked as it's old... but you can create a new thread in the forum. 

Forum home

Advertisement

 
Blog  |  Forum     more >> Archive | Feed | Google's blogs | About
Advertisement

 

This site unofficially covers Google™ and more with some rights reserved. Join our forum!